DosBox co udało się uruchomić....

  • 145 Odpowiedzi
  • 60674 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline Bat.

  • Homofob i seksista
  • ******
  • 3315
  • Płeć: Mężczyzna
  • Skąd: Śląsk
    • Deskorolka Underflip
  • Sprzęt: Dell Axim X51v | Blackberry 8110, 9700, PlayBook
DosBox co udało się uruchomić....
« Odpowiedź #120 dnia: Październik 21, 2006, 11:06:35 »
Hahaha xoen, a mówiłem, że stary Jazz musi ruszyć! Moja ulubiona gierka :D Nie ma jaj, muszę odpalić DB - mam ten sam problem co processor. Zaraz pobawię się configiem aż ruszy, hehe.
Dzięki za przetestowanie!

damn
Chyba to faktycznie nie chodzi na WM5 :( Wyłączyłem nawet wszystkie nakładki i programy działające w tle - mimo wszystko - zawiecha całego pocketa po odpaleniu, albo DosBox jest niewidzialny jako górna warstwa. Może GAPI mi potrzeba?

edit 2

Udało mi się go zmusić do działania. Niestety nawet z wyłączonym RealVGA mam tylko 1/4 ekranu reagującą na dotyk, więc będę musiał na ślepo próbować :)

edit3

Nie udało mi się na ślepo tego robić, to wrzuciłem do autoexeca :D Chodzi!!!!!!
Nie wiem ile wyciąga, bo nie mogę korzystać z klawiatury, ale jest grywalne :) Menu chodzi wolno, ale sama gra szybko. Tylko czemu obraca mi pocketa ten dosbox na landscape left to ja nie wiem, ciężko się tak gra. I dźwięku nie umiem ustawić :(

*

Offline DinthKSC

  • ****
  • 962
  • Płeć: Mężczyzna
    • Prywatny blog
  • Sprzęt: iPAQ h4150
DosBox co udało się uruchomić....
« Odpowiedź #121 dnia: Październik 21, 2006, 13:36:57 »
Dziala mi Civilization :D Nie spodziewalem sie tego. Nawet mimo ze wolna jest grywalna na moim 206MHz (narazie z wylaczonym GAPI).
Mam jednak 2 pytania: jak zrobic normalniejsza myszke w DosBoxie (tj klika tam gdzie tapne, a nie przesuwanie kursora rownolegle do rysika - a nie tam gdzie rysik), oraz drugie - jak uruchomic Settlersow - wyskakuje mi blad XMIDI.

GAPI mi nie dziala pod DosBoxem, na pierwszy rzut oka wyglada to jak smietnik na ekranie, na drugi rzut wyglada tak jakby aplikacja uruchomila sie w trybie portrait w rozdzielczosci 320x240 nadmiarowe piksele z jednej linii przenoszac na nastepna.

*

Offline Kapitan Pazur

  • *****
  • 11296
  • Sprzęt: iPhone 5, Xperia Z3 Compact
DosBox co udało się uruchomić....
« Odpowiedź #122 dnia: Październik 21, 2006, 17:14:43 »
Cytat: "BatSk8"
Tylko czemu obraca mi pocketa ten dosbox na landscape left to ja nie wiem, ciężko się tak gra.

kierunek obracania ekranu ustawiasz sobie w konfigu: lefthand=true lub false

*

Offline processor

  • ****
  • 691
  • Płeć: Mężczyzna
    • Radio i telewizja w Małopolsce
  • Sprzęt: XDA Exec, iPAQ 3870
DosBox co udało się uruchomić....
« Odpowiedź #123 dnia: Październik 21, 2006, 18:42:52 »
Cytat: "DinthKSC"
jak uruchomic Settlersow - wyskakuje mi blad XMIDI.


A może w ich ustawieniach wyłączyć dźwięk??

*

nothin

DosBox co udało się uruchomić....
« Odpowiedź #124 dnia: Październik 21, 2006, 20:49:48 »
myślę, że:

setup.exe i nosound a potem odpalamy z quickn.

*

Offline DinthKSC

  • ****
  • 962
  • Płeć: Mężczyzna
    • Prywatny blog
  • Sprzęt: iPAQ h4150
DosBox co udało się uruchomić....
« Odpowiedź #125 dnia: Październik 22, 2006, 13:44:42 »
GAPI mi niestety dalej nie dziala, wszystko wyglada na to ze driver nie potrafi obrocic obrazu. Czy da sie uruchomic Dosboxa w trybie 240x240 square screen? w ten sposob mozna by to bylo sprawdzic.
tpadmouse ustawilem na false, w wiekszosci gier mysz zaczela dzialac normalnie, niestety w settlersach przestala dzialac wogole, po tapnieciu kursor lata po calym ekranie z wyjatkiem miejsca w ktorym tapnalem ekran :/

Aha udalo mi sie uruchomic DosBoxa z ustawieniami core=dynamic; display=overlay i wydaje mi w miejscach w ktorych bardzo spowalnial teraz dziala duzo szybciej.

*

Offline KotLarry

  • ***
  • 351
  • Płeć: Mężczyzna
  • Sprzęt: FS Pocket Loox 420 -> i780 6.1 96dpi -> omnia pro4
DosBox co udało się uruchomić....
« Odpowiedź #126 dnia: Październik 22, 2006, 14:34:30 »
Ipaq miał spoere problemy z GAPI. Miałem 3870 i było tragicznie.
Właściwie nic nie było. A poneiważ od modelu 36XX różnił się
jedynie slotem na kartę, ew. BT i ilością ramu to podejrzewam,
że może być tak samo skopany jeśli chodzi o GAPI.
Pozdrawiam!
MK.

*

Offline DinthKSC

  • ****
  • 962
  • Płeć: Mężczyzna
    • Prywatny blog
  • Sprzęt: iPAQ h4150
DosBox co udało się uruchomić....
« Odpowiedź #127 dnia: Październik 22, 2006, 14:37:21 »
Na 3660 problemow z GAPI nigdy nie mialem, teraz uzywam 3850

BTW. XCOM Apocalipse nie rusza na DosBoxie N0pa

*

Offline Kapitan Pazur

  • *****
  • 11296
  • Sprzęt: iPhone 5, Xperia Z3 Compact
DosBox co udało się uruchomić....
« Odpowiedź #128 dnia: Październik 22, 2006, 14:53:05 »
konkretnie to problemy są z GAPI w trybie landscape, w pionie jest wszystko OK

*

nothin

DosBox co udało się uruchomić....
« Odpowiedź #129 dnia: Październik 22, 2006, 15:25:47 »
niestety nie znam metody na tryb portrait, to byłoby wybawienie...


a tu
http://www.pdaclub.pl/forum/viewtopic.php?t=49260
jest paczka dosboxów, wszystkich, jakie znalazłem.

co do 1/4 ekranu... szukaj w konfigu

[render]
# frameskip -- How many frames dosbox skips before drawing one.
# aspect -- Do aspect correction.
# scaler -- Scaler used to enlarge/enhance low resolution modes.
# Supported are none,normal2x,advmame2x,advmame3x,advinterp2x,interp2x,tv2x.

frameskip=5
aspect=false
scaler=none


scaler na normalx2 może...?

co do tego nieszczęsnego ciągania myszy... nic się nie da zrobić chyba, tlko pdosbox ma możliwość obsługi myszy typu klik=ruch....

*

Offline DinthKSC

  • ****
  • 962
  • Płeć: Mężczyzna
    • Prywatny blog
  • Sprzęt: iPAQ h4150
DosBox co udało się uruchomić....
« Odpowiedź #130 dnia: Październik 22, 2006, 17:57:25 »
Cytuj
co do tego nieszczęsnego ciągania myszy... nic się nie da zrobić chyba, tlko pdosbox ma możliwość obsługi myszy typu klik=ruch....

w innych grach dziala dobrze w Dosbox 0.63 n0p'a. Tylko w Settlersach nie dziala. Moze to wina nie emulatora tylko gry, ew. emulowanego sterownika myszki?

*

nothin

DosBox co udało się uruchomić....
« Odpowiedź #131 dnia: Październik 22, 2006, 18:11:03 »
sprawdź na stronie n0pa CVS build.

on chyba działał ok..jeśli nie szukaj w paczce z dosboxami w/w.

DosBox co udało się uruchomić....
« Odpowiedź #132 dnia: Październik 25, 2006, 15:44:47 »
Udało mi się uruchomić Ascendancy (trochę ekran za mały i nie da się czytac + tempo gry nie za wielkie, ale da sie przeżyć)

Summoning - z tego sie bardzo cieszę, lae muszę wygrzebać starą instrukcje od tej gry, gdyz trzeba wstukać kod, więc nie wiem jak sama rozgrywką

Odp: DosBox co udało się uruchomić....
« Odpowiedź #133 dnia: Wrzesień 01, 2007, 09:47:34 »
Witam, na dosbox 0.63 udało mi się właśnie uruchomić jedną z moich ulubionych gierek czyli Goblins3.

Gierka chodzi.... prawie bardzo dobrze, co jakiś czas tnie się dźwięk i przystaje na moment obraz. Czy da się coś z tym zorbic? Jakiś plik konfiguracyjny? mam mio p550. Czy może na innym emulatorze próbować?

Dzięki za odpowiedź

*

Offline malo

  • 16
  • Płeć: Mężczyzna
  • Sprzęt: FS Loox N560, WM6
Odp: DosBox co udało się uruchomić....
« Odpowiedź #134 dnia: Wrzesień 01, 2007, 16:26:19 »
Witam, na dosbox 0.63 udało mi się właśnie uruchomić jedną z moich ulubionych gierek czyli Goblins3.

Gierka chodzi.... prawie bardzo dobrze, co jakiś czas tnie się dźwięk i przystaje na moment obraz. Czy da się coś z tym zorbic? Jakiś plik konfiguracyjny? mam mio p550. Czy może na innym emulatorze próbować?

Dzięki za odpowiedź

Spróbuj ScummVM (http://www.scummvm.org/) - działa też na nim wiele innych klasycznych przygodówek (głównie LucasArts).
Dosbox to moim zdaniem ostateczność, po włączeniu dźwięku trudno zapewnić w nim sensowną prędkość działania.

Odp: DosBox co udało się uruchomić....
« Odpowiedź #135 dnia: Wrzesień 01, 2007, 17:10:00 »
dzięki będę czytał, w razie wątpliwości zaalarmuje
Napisane: Wrzesień 01, 2007, 16:31:59
CHŁOPIE CHODZI JAK BURZA!!!
Napisane: Wrzesień 01, 2007, 17:06:37
Mam tylko jeden program, po najechaniu kursorem na element nie podświela nazwy.

Np na pierwszej planszy powinienem mieć chest itd. Wiem żę to są aktywne przedmioty, ale powinny się podświetlac.

*

Offline malo

  • 16
  • Płeć: Mężczyzna
  • Sprzęt: FS Loox N560, WM6
Odp: DosBox co udało się uruchomić....
« Odpowiedź #136 dnia: Wrzesień 01, 2007, 22:57:42 »
Np na pierwszej planszy powinienem mieć chest itd. Wiem żę to są aktywne przedmioty, ale powinny się podświetlac.

Pewnie bug engine-u w scummvm. Co ciekawe po przemieszczeniu kursora przyciskami napisy sie pojawiaja. W goblins 2 np. tego problemu nie ma.

btw. zrobil sie mały offtopic :)

Odp: DosBox co udało się uruchomić....
« Odpowiedź #137 dnia: Wrzesień 02, 2007, 00:18:32 »
dokładnie jest jak mówisz.

*

Offline MFC

  • *
  • 82
  • Płeć: Mężczyzna
  • Sprzęt: X800
Odp: DosBox co udało się uruchomić....
« Odpowiedź #138 dnia: Luty 29, 2008, 23:57:27 »
Witam, czy udalo sie komus odpalić Space Hulk?

Mi na poczatku wyskakuje logo, etc. potem wywala i jest komunikat error in Midi code. Dodam tylko ze w czasie uruchomiania, strasznie ciol sie dzwiek.

Ok zaczynam to ogarniac. W zależności od tego co zminenie w pliku config mam emuluje inne rzeczy, tak?
Dlatego tez w grze space hulk po intro wyskakuje mi midi error. A jak zaowazylem po odpaleniu dosboxa standardowo laduje soundblaster. Kombinuje jak wlaczyć emulacje midi a wylaczyć soudnblastera, zrobilem tak:

[midi]
# mpu401      -- Enable MPU-401 Emulation.
# intelligent -- Operate in Intelligent mode.
# device      -- Device that will receive the MIDI data from MPU-401.
#                This can be default,alsa,oss,win32,coreaudio,none.
# config      -- Special configuration options for the device. In Windows put
#                the id of the device you want to use. See README for details.

mpu401=true
intelligent=true
device=default
config=

[sblaster]
# type -- Type of sblaster to emulate:none,sb1,sb2,sbpro1,sbpro2,sb16.
# base,irq,dma,hdma -- The IO/IRQ/DMA/High DMA address of the soundblaster.
# mixer -- Allow the soundblaster mixer to modify the dosbox mixer.
# oplmode -- Type of OPL emulation: auto,cms,opl2,dualopl2,opl3.
#            On auto the mode is determined by sblaster type.
# oplrate -- Sample rate of OPL music emulation.

type=none
base=220
irq=7
dma=1
hdma=5
mixer=true
oplmode=auto
oplrate=11025

Niestety po wlaczeniu dosboxa nic nie moge zrobic, tzn, nic pisac. Jakies rady jak uruchomic to midi a wylaczyc Soundblaster?
« Ostatnia zmiana: Marzec 01, 2008, 20:35:56 wysłana przez MFC »

*

Offline dissident

  • **
  • 198
  • Płeć: Mężczyzna
  • Sprzęt: HTC HD2
Odp: DosBox co udało się uruchomić....
« Odpowiedź #139 dnia: Wrzesień 26, 2008, 19:23:56 »
Poczytalem, poszukalem, ale mam pytanie, skad wy bierzecie te gry?

Mam dwie gierki ktore odpalam pod dosboxem na pc, i te same gry moge normalnie wrzucic na pocketa, czy moze specjalne rozszerzenia/pliki sa na ppc ??
"If you hate something don't you do it too..."

*

Offline Kapitan Pazur

  • *****
  • 11296
  • Sprzęt: iPhone 5, Xperia Z3 Compact
Odp: DosBox co udało się uruchomić....
« Odpowiedź #140 dnia: Wrzesień 26, 2008, 21:32:17 »
te same - normalne gry dosowe
no chyba że nie pójdą...

*

Offline dissident

  • **
  • 198
  • Płeć: Mężczyzna
  • Sprzęt: HTC HD2
Odp: DosBox co udało się uruchomić....
« Odpowiedź #141 dnia: Wrzesień 27, 2008, 01:19:08 »
te same - normalne gry dosowe
no chyba że nie pójdą...


ee no to fajnie, potestuje sie kilka :) dzieki.
"If you hate something don't you do it too..."

*

Offline Airice

  • ***
  • 271
  • Sprzęt: HP 114 + panasonic SDHC 4GB
Odp: DosBox co udało się uruchomić....
« Odpowiedź #142 dnia: Wrzesień 29, 2008, 13:46:24 »
mi sie udało odpalic ...

Ishar 1/2 |3 nie odpala
eye of beholder 1/2 działa
lords of the realm idealnie!
cos tam knight of kingdom romance czy jakos tam...

i cos tam byle ale wszystko wywalilem... ;p

*

nothin

Odp: DosBox co udało się uruchomić....
« Odpowiedź #143 dnia: Wrzesień 29, 2008, 13:49:02 »
Cytuj
lords of the realm idealnie!

oooo, sprawdzę!

upd: działa rewelacyjnie! sprawdzę pod pocketdosem, bo ma lepszą obsługę mychy...

Cytuj
Witam, czy udalo sie komus odpalić Space Hulk?
u mnie śmigał, swego czasu grałem...
« Ostatnia zmiana: Wrzesień 29, 2008, 13:59:23 wysłana przez nothin »

*

Offline Airice

  • ***
  • 271
  • Sprzęt: HP 114 + panasonic SDHC 4GB
Odp: DosBox co udało się uruchomić....
« Odpowiedź #144 dnia: Październik 08, 2008, 18:43:23 »
nothin jabys miał chwilke czasu looknij jak dziala zapis w Ishar 1.. bo co mi dziwnie dziala... i może u Ciebie zacznie współpracować ishar 3

Odp: DosBox co udało się uruchomić....
« Odpowiedź #145 dnia: Grudzień 20, 2010, 21:46:07 »
jestem żielony  zainstalowałam dosmoxa ina telefon i o mam zrobić zeby czytało mi gry