Autor Wątek: GG działa pod 4.1 bez Jabbera  (Przeczytany 1629 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline halif

  • Newbie
  • Wiadomości: 35
GG działa pod 4.1 bez Jabbera
« : Luty 08, 2008, 08:15:50 »
Być może dla wielu nie będzie to żadne novum, ale GG działa i nie trzeba do tego Jabbera. W swoim czasie, w 2005 roku powstał program o nazwie GGClone. Działał on ładnie do czasu, jak zmieniły się adresy serwerów. Nie posiadał też możliwości importu danych z serwera GG. Porozmawiałem z autorem, po testowałem i udało mi sie zmusić do działania jego ostatnią wersję dla PocketPC 2007 z naszym, poczciwym 4.1. Zatem do rzeczy. Aby mieć gadulca trzeba niestety zainstalować oba Frameworki. Poprawcie mnie jeżeli się mylę, Framework Compact 2.0, nie posiada w sobie bibliotek .NET Framework Compact 1.0? Możecie spróbować zainstalować tylko 2.0 i zobaczcie czy pójdzie. Mój sposób, przetestowany i działa:
- ściagasz i instalujesz .NET Framework Compact 1.0 (http://pdaclub.pl/dl/file_view.php?f_cat=0&f_str=framework&f_author=43&sortby=t&sort=asc&f_id=62
-ściągasz i instalujesz .NET Framework 2.0 (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4)
(podczas szukania odnośników znalazłem opis M$, że 2.0 wspiera uruchamianie z .NET 1.0, zatem powinno być konieczne zainstalowanie tylko 2.0. Sprawdźcie i powiedzcie)
- teraz należy ściągnąć i zainstalować GGClone dla ARMa, dle 4.x: http://www.mksoft.pl/GGdotNet2/GGCloneForPocketPC/bin/GG%20Clone_PPC.ARM.CAB

Po instalacji mamy GG w wersji 0.9 o mocno ograniczonej funkcjonalności. Teraz ściągamy wersję "Uniwersalną" 0.12:
(http://www.mksoft.pl/GGdotNet2/GGCloneForPocketPC/bin/GGCloneforPPC.zip)
i ręcznie podmieniamy plik GGClone.exe na naszym Simpadzie tym, który jest w ostatnim archiwum.

Po wszystkim włączamy GGClone na Simpadzie, importujemy kontakty i cieszymy się mobilnym GG. Prosto i skutecznie*

*przynajmniej w moim przypadku skutecznie

Teraz moja konfiguracja:
- Simpad SLC, oba Frameworki, cały (oprócz DX.dll, ten jest od GAPI) FAKE.zip przegrany do głównego karta wifi Orinoco Silver->Gold i u mnie działa.
Krzysztof Mackojć, autor tego oprogramowania napisał mi, że import kontaktów zależy od wersji programu, którą dokonywaliśmy eksportu, więc jak się nie powiedzie to możecie probować jeszcze raz dokonać eksportu na desktopie i potem importu na CE.

Może nie sjest to wielkie odkrycie, ale jest to rozwiązanie dla tych, których przeraża perspektywa przeprawy z Jabberem. W razie pytań służę pomocą. Acha,  Frameworki z linków nie są tymi, które instalowałem, tylko z Googla, więc wersje mogą być inne. Jak będą problemy to porównam wersje. Jeszcze jedno. Mnie Zainstalowanie Frameworka 2.0 zajęło parę chwil, gdyż potrzebuje on względnie dużo pamięci podczas instalacji. Nie wiem czemu. Udało mnie się to tylko na praktycznie czystym CE.NET 4.1

Powodzenia.


PDAclub.pl

GG działa pod 4.1 bez Jabbera
« : Luty 08, 2008, 08:15:50 »
R E K L A M A:


Offline Kajetan Krykwiński

  • Clubowicz
  • ******
  • Wiadomości: 6199
    • Kocham Wieluń: dziennik internetowy poruszający zagadnienia związane z Wieluniem i okolicami
  • Sprzęt: Karton antyków. Albo i dwa.
Odp: GG działa pod 4.1 bez Jabbera
« Odpowiedź #1 : Luty 15, 2008, 12:21:37 »
Jest jeszcze program GGCE no i nie wiem jak będzie na CE .net 4.1 ale opisałem odpalenie MobileGadu...