Autor Wątek: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty  (Przeczytany 26965 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline PioMul

  • Newbie
  • Wiadomości: 27
  • Sprzęt: 5,2" Honor 9; tablety 7" Lenovo, Overmax, Archos
Odpowiadam tu na pytanie telefoniczne, które zadało mi dwóch kolegów. Myślę, że to miejsce odpowiednie. Chodziło im o to, że Vivo S6 bardzo kiepsko im czyta sygnały GPS, nie łapie fiksa albo czyni to godzinami i po drodze długo przelicza trasę, czasem się spóźnia.
Tak nie musi być.
Pomijam już fakt, że po Modecomie i paru innych, kiedy kupiłem Vivo S6, odczułem ulgę ze względu na bardzo dobry ekran Vivo. Widać nawet w dość ostrym słońcu, kolory są żywe. Lepiej ekran reaguje na dotyk, nic spod palca nie ucieka, nie wywołuje się nieodpowiednia funkcja.
Po zebraniu pewnego doświadczenia mogę spokojnie powiedzieć, że Vivo S6 to szybka nawigacja, która bardzo łatwo łapie fiksa, prawie nie czeka się na obliczenie i ustawienie trasy, nawet 500-kilometrowa (większych jazd nie miałem). Trzeba tylko dobrze ustawić w niej Automapę w zakresie obsługi GPS.
Automape zainstalowałem na karcie od nowa, żeby wywalić pozostałości po Modecomie MX3 HD (zachowałem tylko plik z ulubionymi - default.fav i wgrałem go do odpowiedniego katalogu karty z zainstalowaną AM dla Vivo).
Po ustawieniu ścieżki do Automapy trzeba uruchomić ten program (najlepiej klawiszem na górnej krawędzi, ale przy podłączonym zasilaniu). W Automapie w ustawieniach GPS-u ustawić port - nie ma to być: COM1 auto, ale samo COM1 - oraz szybkość odczytu na 38400. Wyłączyć "otwieraj tylko gdy używany" i "czytaj w oddzielnym wątku", bo inaczej będzie się spóźniać i pokazywać wskaźnik auta o jakieś 300 m przed punktem rzeczywistym na drodze.
Najważniejsze dla fiksa: trzeba  sposobem znanego forumowicza Biluni zmienić (w zwykłym notatniku Windows) plik tekstowy Automapy, zawierający parametry odczytu sygnałów GPS, "gps.settings" (jest w folderze Profile/wybierz ten, którego używasz, u mnie Osobowy). Należy w nim zmienić wartości liczbowe dwóch parametrów na "1", następująco: AutodetectMinPort=1, AutodetectMaxPort=1 (liczba jest odpowiednikiem numeru portu).
Po takiej zmianie nawigacja szuka sygnału tylko dla jednego portu, czyli COM1, a nie dla wszystkich, dzięki czemu nieporównanie szybciej łapie fiksa. Dobrze trzyma też sygnał na drodze.
Warto w samym urządzeniu przynajmniej raz na wolnym powietrzu wykonać reset sygnałów GPS (do tej funkcji wejście jest z menu urządzenia, nie z Automapy). Czy to dostraja GPS, nie wiem, ale odniosłem wrażenie, że bardzo pomogło. (Na krótko pokazały się też sygnały z GLONASS, z numerami ponad 70, ale myślę, że nie mają istotnego wpływu na nawigowanie - szybko się zmieniają, łatwo zanikają i widzę ich maksymalnie 2. Wiadomo, jak to z tymi ze Wschodu - prędzej namieszają niż pomogą).
Żeby nawigacja jeszcze szybciej pracowała, radzę dać widok mapy bez nieba, taki najprostszy 2D-3D. Automapa ma wtedy mniej operacji do wykonania.
Tu i ówdzie piszą, że nie widzą różnicy w działaniu między MX3 (HD) a Vivo S6. To dziwne, bo Vivo ma dwa razy więcej pamięci operacyjnej (256 mb, MX3 HD ma 128) i szybszy procesor (800 mHz, MX3 HD - 664). Vivo jest o parę lat technologicznie świeższe. Widocznie nikt nie sprawdzał działania doświadczalnie, czyli nie uruchomił dwóch nawigacji obok siebie i nie porównał. My ze szwagrem porównaliśmy. Różnica jest spora. Vivo w niektórych sytuacjach okazuje się kilka razy szybsza, np. przeliczenia tras robiła w czasie niemal rzeczywistym, a w Modecomie to się jednak ciągnęło.
Nie wiem, jak będzie z trwałością urządzenia, bo na forach piszą dramatyczne rzeczy, ale po 3 miesiącach nic się na razie nie dzieje, więc może polscy właściciele firmy nacisnęli, a Chińczycy poprawili jakość produkcji, a to z powodu bardzo dużej liczby reklamacji. W każdym razie na moim etapie użytkowania jest nieźle.

« Ostatnia zmiana: Kwiecień 24, 2015, 11:08:00 wysłana przez PioMul »

PDAclub.pl

R E K L A M A:


Offline angler22

  • Redaktor
  • Moderator
  • *****
  • Wiadomości: 4793
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #1 : Kwiecień 23, 2015, 08:53:44 »
Część porad wprawdzie się wyklucza (ustawienie ręcznie portu GPS powoduje brak zasadności zmiany parametrów "autodetectmin" i max), jednak całość może być bardzo przydatna. Nie miałem do czynienia z tym modelem, ale doświadczenia z zabawy z innymi nawigacjami podpowiadają, że często winnym problemów jest wadliwy plik almanachu (w niektórych nawigacjach zapisywany jest on na trwałej pamięci flash). O ile producent porządnie podszedł do opracowania softu i w opcji obsługi GPS dodał "reset", który RZECZYWIŚCIE kasuje wszystkie potencjalnie wadliwe pliki, to problemu nie ma. Jednak bywa (choćby w przypadku Larka 50.2), że reset z menu nie załatwia sprawy (kasuje tylko jeden z dwóch plików) i bez ręcznej poprawki nawigacja przestaje łapać fix'a. Po usunięciu obu plików nawigacja zaczyna działać bez problemu.
Tak że jeśli porady PioMul nie pomogą, można spróbować poszukać na pamięci flash plików związanych z GPS'em (niestety trzeba się na tym trochę znać, żeby wiedzieć które to).


Offline PioMul

  • Newbie
  • Wiadomości: 27
  • Sprzęt: 5,2" Honor 9; tablety 7" Lenovo, Overmax, Archos
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #2 : Kwiecień 24, 2015, 02:38:43 »
Zaproponowane (i sprawdzone przeze mnie) "ręczne" ustawienie portu GPS-u (tzn. wybranie COM1) i jednocześnie zmiana wspomnianych parametrów w pliku gps.setting wcale się nie wykluczają, mogą się co najwyżej dublować / nakładać.
Zamiast teoretyzować (a właściwie zgadywać), lepiej zbadać, co też na długo przed napisaniem postu uczyniłem. Działa tylko owo "zdublowanie", to znaczy ustawienie na czysty COM1 + zmiana w pliku. Wszystkie inne warianty ustawień wraz z ingerencją w plik i bez niej - są bezskuteczne. To dowodzi błędu ustawienia wstępnego. Zarówno NavRoad, jak i Automapa powinny były o to zadbać, a tak strzelają sobie w stopę, bo przez to Vivo S6 ma złą opinię (jak widać, niesłusznie).
W NavRoad Vivo S6 (firmware wersja 1.2S) reset odbioru sygnałów GPS czyści do cna, to jest pewne, więc jeśli są jakieś błędy, to odświeżenie powinno poprawić odbiór (ale jak pisałem: czy to naprawdę daje jakąś poprawę w nawigowaniu, nie wiem; wydaje mi się, że powinno, jednak tego nie badałem). W każdym razie reset nic nie popsuje.
Wreszcie przypomnę, że jest tu mowa wyłącznie o konkretnym urządzeniu do nawigacji, co jest zaznaczone w tytule wątku. Na przykład w Modecomie MX3 HD i podobnie w MX2 HD wyłączenie parametru "w osobnym wątku" nie dawało żadnego efektu, a w Vivo odwrotnie - znaczne pogorszenie.

« Ostatnia zmiana: Kwiecień 24, 2015, 02:40:56 wysłana przez PioMul »

Offline angler22

  • Redaktor
  • Moderator
  • *****
  • Wiadomości: 4793
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #3 : Kwiecień 24, 2015, 09:02:41 »
Dublowanie to może rzeczywiście lepsze słowo, jednak ręczne ustawienie COM na 1 pomija przecież całą procedurę "autodetekcji", a tym samym zmiany w pliku przestają mieć sens. Co innego, jeśli popatrzymy na sprawę odwrotnie - jeśli tylko zawęzimy "obszar" autodetekcji do COM 1 do 1, a mechanizm detekcji ogólnie nie radzi sobie w Vivo S6, to tak naprawdę nic nie osiągniemy, dopóki nie ustawimy COM 1 ręcznie :)
Co do reszty, to tak jak pisałem, wskazówki mogą być bardzo przydatne, bo zachowanie się AM na różnych urządzeniach w zależności od ustawień parametrów "czytania portu w osobnym wątku" czy też "otwierania gdy potrzebny" jest diametralnie różne. Dodatkowo podniesienie baudrate z domyślnego w AutoMapie 4800, na proponowane przez Ciebie 38400 może zapobiec "zatykaniu" się portu COM, co ponoć zdarzało się w przypadku bardziej zaawansowanych chipsetów GPS (a Vivo w związku z teoretyczną współpracą z Glonass z pewnością jest takim bardziej zaawansowanym sprzętem).


Offline PioMul

  • Newbie
  • Wiadomości: 27
  • Sprzęt: 5,2" Honor 9; tablety 7" Lenovo, Overmax, Archos
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #4 : Kwiecień 24, 2015, 11:06:50 »
Baudrate 38400 ustawia instalacja Automapy wraz z obsługą NavRoada, więc to nie jest mój wybór. Sprawdzałem też inne wartości z wykazu, ale ta wydaje się w Vivo S6 optymalna.


Offline angler22

  • Redaktor
  • Moderator
  • *****
  • Wiadomości: 4793
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #5 : Kwiecień 24, 2015, 11:37:40 »
O widzisz, tego nie wiedziałem - na czystej instalce "od zera" z zaznaczeniem dodatku Navroad zawsze ustawia 38400?


Offline PioMul

  • Newbie
  • Wiadomości: 27
  • Sprzęt: 5,2" Honor 9; tablety 7" Lenovo, Overmax, Archos
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #6 : Kwiecień 26, 2015, 01:17:29 »
Wydaje mi się, że to już jest wpisane w plikach obsługi NavRoada dostarczonych przez Automapę, a nie w samym NavRoadzie. Jednak głowy nie dam. W czasie prób kilka razy instalowałem AM od zera, zawsze ustawiało się od razu na 38400, COM1 Auto oraz na "tak" "w osobnym wątku".
Zauważyłem też, że Automapa nie radzi sobie z: 1) moim wychodzeniem do menu nawigacji (przez "minimalizuj" albo "słuchawkę") i następnie 2) powróceniem do nawigowania przez wciśnięcie pola "WEB" (tak robię, żeby się BT z DUN-em nie wyłączał). AM potrafi się wtedy zawiesić (choć nie zawsze) i muszę restartować. Sprawdzę jeszcze, czy reset (przycisk z tyłu nawigacji) nie zadziała pozytywnie, może odkładają się jakieś resztki w pamięci NandFlash urządzenia, które po jakimś czasie mulą. Może po prostu trzeba je forsownie wywalić. Na komputerowe grzebanie w bebechach zwyczajnie nie mam czasu.
Uważam, że te problemy (a może tylko problemiki) to wina Automapy albo Windowsa (chyba raczej AM). Różne ustawienia pamięci w Automapie pokazały, że zawiechy są najrzadsze, kiedy limit pamięci jest ustawiony na 12 MB (a POI na minimum), bo przy 10 i w dół oraz więcej niż 12 potrafi brzydko lagować albo nawet zatrzymywać się całkowicie. AM chyba nie korzysta z całej dostępnej pamięci operacyjnej nawigacji, która przecież jest większa niż w innych GPS-ach, albo jej nie zwalnia, kiedy trzeba. A gospodarka pamięcią to przecież podstawa opracowywania wszelkich aplikacji. Może po paru latach, kiedy Vivo S6 wyjdzie z użytku, AM się poprawi. Napisałem do nich, ale odpowiedzieli tylko, że zbadają problem. Nie lubią, jeśli im się podpowiada rozwiązania.


Offline andrep

  • Clubowicz
  • ***
  • Wiadomości: 415
  • Sprzęt: MioP550,VivoS6,Samsung J7 AM PL Android
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #7 : Maj 04, 2015, 22:29:13 »
Witam
Kolego PioMul mam vivo s6 od Lipca 2014, i jak do tej pory żadnych problemów opisanych na różnych forach (może trochę się grzeje ale o tym się przekonałem jak biorąc  do ręki).Z ciekawości zastosowałem zmiany proponowane przez Ciebie i potestuję jak będzie różnica to dam znać ,jeżdżę  mało więc to potrwa. U mnie po instalacji czystej był ustawiony com1(nie auto),w  AutodetectMaxPort=1 było 9 natomiast plik AutodetectMinPort=1 było 1 więc nie zmieniałem.Dzięki serdeczne za dobre rady.
Pozdrawiam


Offline PioMul

  • Newbie
  • Wiadomości: 27
  • Sprzęt: 5,2" Honor 9; tablety 7" Lenovo, Overmax, Archos
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #8 : Maj 17, 2015, 02:41:10 »
Ciekaw jestem Twoich prób i doświadczeń. Vivo S6 coraz bardziej mi się podoba, a ostatnio sporo z niej korzystam i zero problemów. Może raz na 8 tys. km musiałem zresetować (tzn. wyłączyć i włączyć), bo ekran zrobił się martwy, ale w innych nawigacjach u mnie była to norma. "Dotarła się"?
W każdym razie fiksa łapie szybciej niż Modecom MX3 HD.
Ostatnio dla draki próbowałem też programiku NavRoad FREE wgranego na kartę (program jest na stronie NavRoada, można wgrać dowolne mapy od tak zwanej społeczności itd.). To raczej amatorska robota, ale chodzi bez łachy. Może się przydać za granicą, jeśli się nie ma AutoMapy EU. Ja jednak dla Europy wolę Sygica na smartfonie z Androidem (parę złotych kosztowało, ale jest dożywotnio i sam aktualizuje program oraz mapy przy włączonym WiFi). Świetny, bo chyba oparty na mapach TomToma. Szukam Sygica na Win CE 6.0, ale nie mogę w necie znaleźć. Gdybym znalazł, zainstalowałbym zamiast Navroada FREE jako alternatywę dla AutoMapy (AM - Polska, Sygic - Europa).


Offline andrep

  • Clubowicz
  • ***
  • Wiadomości: 415
  • Sprzęt: MioP550,VivoS6,Samsung J7 AM PL Android
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #9 : Maj 17, 2015, 11:21:02 »
Witam
Zrobiłem parę "tras" po Krakowie i muszę powiedzieć że jest może lepiej ale to chyba złudzenie :), fiksa łapie po chwili może nieco szybciej, natomiast drugie uruchomienie np. po 2 godzinach to wręcz wrażenie jakby GPS był cały czas włączony łapie w momencie. Tak jak pisałem wcześniej byłem i jestem zadowolony ze sprzętu, a ustawienia zostawiam kolegi :ok:. Mało jeżdżę 1-2 trasy ( po PL)  w roku więc jak na razie innych objawów nie zaobserwowałem. Z tel. łączy się bez problemów. Dodam że z kamerą cofania fajnie współpracuje.
 Pozdrawiam

« Ostatnia zmiana: Maj 17, 2015, 11:23:29 wysłana przez andrep »

Offline kafel1969

  • Newbie
  • Wiadomości: 3
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #10 : Czerwiec 05, 2015, 09:44:10 »
Witam
Czy te porady dotyczą tylko Vivo,czy całej serii S6 ?
Ja mam Auro S6 i nie wiem czy mogę z nich skorzystać.


Offline jartro

  • Clubowicz
  • ****
  • Wiadomości: 547
  • Sprzęt: Auro S 6, AM EU aktualna, TomTom Go 6000, 6200
  • VIP Level: 150
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #11 : Wrzesień 11, 2015, 14:09:15 »
Mam też Auro S 6.
Po zaznaczeniu navroad autostart w instalacji AM port i jego wartość ustawiają się jak podano.
Nawi uruchamia się bez problemu jeśli jest na karcie. Trzeba zaznaczyć w navroad: autorun i sd

« Ostatnia zmiana: Wrzesień 11, 2015, 14:11:43 wysłana przez jartro »

Offline vjanusz

  • Newbie
  • Wiadomości: 3
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #12 : Grudzień 09, 2015, 16:18:48 »
Posiadam VIVO S6 półtora roku i generalnie jest jest ok. Satelity wykrywa bardzo szybko, poprzedni NavRoad NR560BF robił to zdecydowanie dłużej. Niemniej jednak podczas jazdy wcześniej wyznaczoną trasą VIVO S6 ni z gruszki ni z pietruszki podaje komunikat "Jesteś poza trasą, wyznaczam nową" i co ciekawe trasa się nie zmienia bo nawet nie było żadnego skrzyżowania, cały czas podświetlana jest na niebiesko i komunikat nie jest już powtórnie powtarzany przez lektora. Zdarza się to zupełnie przypadkowo: na prostej drodze, na łukach dróg a najczęściej na pętlach przy wjazdach i zjazdach na autostrady czy też drogi szybkiego ruchu. Zaznaczam, że posiadam oryginalną i aktualną AM EU. Dzieje się to od samego początku i na wszystkich wersjach AM jakie w tym czasie były wydane. Atakowałem już suport AutoMapy i Navroada /ten ostatni wymienił płytę główną/ i dalej to samo.
 W związku z tym mam pytanie: czy u Was dzieje się podobnie?


Offline zdzis.michal

  • Clubowicz
  • ***
  • Wiadomości: 258
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #13 : Grudzień 09, 2015, 17:23:02 »
Cytuj
ni z gruszki ni z pietruszki podaje komunikat "Jesteś poza trasą, wyznaczam nową" i co ciekawe trasa się nie zmienia


Mam to nagminnie i również podobnie działałem z moim RECO. Bez żadnego skutku. Myślę że częściowo wpływa na to dokładność wyznaczania pozycji i ewentualne odbicia czy zakłócenia sygnału.
Cytuj
Dzieje się to od samego początku

Również na gwarancji miałem wymienioną płytę główną i efekt pozostał.
Co gorsza po ok. 120 km po takim komunikacie odmawia dalszej nawigacji i trzeba przeładować system, co bywa niekiedy niebezpieczne. To również wielokrotnie opisywałem na Forum


Offline vjanusz

  • Newbie
  • Wiadomości: 3
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #14 : Grudzień 09, 2015, 18:11:56 »
To co jest winne za taki stan rzeczy? VIVO czy AutoMapa?


Offline zdzis.michal

  • Clubowicz
  • ***
  • Wiadomości: 258
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #15 : Grudzień 09, 2015, 21:13:46 »
Cytuj
To co jest winne za taki stan rzeczy? VIVO czy AutoMapa?


Nie wiem.
AM jednoznacznie w korespondencji wskazała Navroada i poleciła uaktualnić oprogramowanie, czego u mnie mimo konsultacji z Jamiconem nie dało się zrobić. Proponowali przesłać im sprzęt. Koszt takiej naprawy mógł przekroczyć znacznie połowę kosztu nowego urządzenia, co przy starszych parametrach jest bez sensu. Nie uznali, że od ostatniej wymiany płyty głównej nie minęły dwa lata. Stąd zastanawiam się, czy jak zupełnie padnie nie kupić Modecoma, o czym również jest dosyć mojej i kolegów wpisów w nieco innym miejscu.


Offline xrobcio

  • Newbie
  • Wiadomości: 17
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #16 : Grudzień 10, 2015, 20:22:29 »
A jakiego Modecoma masz na mysli?


Offline zdzis.michal

  • Clubowicz
  • ***
  • Wiadomości: 258
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #17 : Grudzień 11, 2015, 09:35:01 »
Cytuj
A jakiego Modecoma masz na mysli?


Miałem na myśli Modecoma MX4HD. Trochę niepokoi mnie zdanie Sserafina na temat nowych wersji, jego perypetii z SX7 i nowego procesora MStar. Szukałem informacji, jakie procesory mają tzw "markowe" nawigacje, ale nie publikują.

Wracając do poprzedniego wątku:
Cytuj
Niemniej jednak podczas jazdy wcześniej wyznaczoną trasą VIVO S6 ni z gruszki ni z pietruszki podaje komunikat "Jesteś poza trasą, wyznaczam nową"

Ciekawe może być tutaj porównanie zapisu trasy z przebiegiem samej trasy wg mapy. Często zapis trasy przebiega równolegle do samej trasy i to może spowodować podanie takich komunikatów. A to zależy od dokładności odbioru sygnałów z satelity i chyba jakości procesora, a więc urządzenia. Ale to są moje przypuszczenia. Skąd natomiast odmowa dalszego prowadzenia nawigacji z powodu zapychanie się jakichś rejestrów, nie wiem. Przeładowanie poprawia sytuację na jakiś czas.


Offline vjanusz

  • Newbie
  • Wiadomości: 3
Odp: NavRoad Vivo S6 - ustawianie pod Automapę instalowaną z karty
« Odpowiedź #18 : Styczeń 11, 2016, 15:06:08 »
Po instalacji ostatnich map widzę znaczną poprawę. Co prawda ostatnio zrobiłem nie za dużo bo około 250 km różnej klasy drogami i wszystko było ok. Czyżby coś naprawili w AM. Oby tak zostało. Pochwalcie się koledzy jak u Was VIVO S6 chodzi na ostatnich mapach?