Autor Wątek: Automatyczne zestawianie połączenia DUN  (Przeczytany 44417 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline PYJTER

  • Newbie
  • Wiadomości: 35
  • Sprzęt: HTC ARTEMIS, HTC KAISER
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #30 : Październik 05, 2010, 20:04:03 »
Dołącze się do prośby kolegi powyżej czy ktoś mógły zrobić jakiś prosty faq bo ściągnąłem ten mort script i nie wiem co dalej... gdzie wrzucić jakie pliki itp... może Tomek666 przy trzeciej wersji programu wrzuci mniej więcej dla lamerów co i jak...


PDAclub.pl

Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #30 : Październik 05, 2010, 20:04:03 »
R E K L A M A:


Offline Tomek666

  • Newbie
  • Wiadomości: 30
  • Sprzęt: NavRoad 460BT
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #31 : Październik 08, 2010, 12:00:58 »
W odpowiedzi na prośby załączam pakiet, który powinien być łatwiejszy w uruchomieniu. Cały katalog "BTDun" wraz z zawartością należy umieścić w katalogu SDMMC, a następnie uruchomić skrypt Install_NavRoad.mscr. Wszystkie niezbędne narzędzia są już w katalogu "BTDun". Więcej informacji w pliku ReadMe.txt.

Zastrzeżenia:
Załączona wersja skryptów nie była testowana w warunkach drogowych i na sprzęcie innym niż NavRoad 460BT. Nie miałem też okazji instalować jej na "czystym" systemie. Jeśli coś będzie nie tak, proszę o informacje.
Skrypty zawierają ścieżki do menu Navroada oraz do Phonelinka, które mogą być specyficzne dla NavRoad 460BT. Nie powinno być natomiast problemu z dostosowaniem ich do innych urządzeń, jeśli tylko korzystają z podobnej wersji Phonelinka.

Pozdrawiam


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #32 : Październik 08, 2010, 12:28:34 »
Dzięki  :ok:, będę testować, ale w przyszłym tygodniu. Pozdrawiam.

Połączone: [time]Październik 09, 2010, 22:06:21[/time]
Wykonałem wszystkie Twoje polecenia i nic z tego nie wyszło. Nic nie chciało się instalować. Kopiowałem BTDun jako katalog, jako zawartość, kopiowałem katalog MortScript; wszystko do CDMMC na różne sposoby i nic. Może coś nie tak robiłem albo czegoś brakuje.
Pozdrawiam.

Połączone: [time]Październik 10, 2010, 10:47:50[/time]
Więc tak: dzisiaj rozpocząłem instalację od nowa. skopiowałem katalog BTDun na kartę. Po uruchomieniu "Install_NavRoad.mscr" pokazał się jakiś komunikat i nic. Na nim nacisnąłem OK i nic. Uruchomiłem "Mortscript.exe" i też jakiś komunikat. Powtórzyłem uruchamianie "Install_NavRoad.mscr" i tym razem komunikat, że "AutoStart" podłączony. Dla pewności zapisu uśpiłem nawi, wybudziłem i wyłączyłem nawigację. Później na różne sposoby włączałem, uruchamiałem AM, wyłączałem nawi i raz na moment pokazał się na mapie ekran z napisem StartingDun. Było połączenie DUN  :proud:. Po tych eksperymentach włączyłem nawigację przez wstawienie do uchwytu. Nastąpiło połączenie BT i czekałem dalej. Później uruchomiła się AM. Następnie było połączenie DUN. Fajnie  :ok:. Zdjąłem z uchwytu nawi, uśpiłem, wybudziłem wstawiając do uchwytu. Nastąpiło połączenie BT i po chwili zestawiło połączenie DUN  :ok: :ok: :ok:. Dalej zobaczę, jak to będzie działać z fixem. Ciekaw jestem, jakie będą u Was wyniki instalacji.
Szacunek dla TOMKA666.
Pozdrawiam.

Połączone: [time]Październik 10, 2010, 21:12:28[/time]

Połączone: [time]Październik 10, 2010, 10:47:50[/time]
Więc tak: dzisiaj rozpocząłem instalację od nowa. skopiowałem katalog BTDun na kartę. Po uruchomieniu "Install_NavRoad.mscr" pokazał się jakiś komunikat i nic. Na nim nacisnąłem OK i nic. Uruchomiłem "Mortscript.exe" i też jakiś komunikat. Powtórzyłem uruchamianie "Install_NavRoad.mscr" i tym razem komunikat, że "AutoStart" podłączony. Dla pewności zapisu uśpiłem nawi, wybudziłem i wyłączyłem nawigację. Później na różne sposoby włączałem, uruchamiałem AM, wyłączałem nawi i raz na moment pokazał się na mapie ekran z napisem StartingDun. Było połączenie DUN  :proud:. Po tych eksperymentach włączyłem nawigację przez wstawienie do uchwytu. Nastąpiło połączenie BT i czekałem dalej. Później uruchomiła się AM. Następnie było połączenie DUN. Fajnie  :ok:. Zdjąłem z uchwytu nawi, uśpiłem, wybudziłem wstawiając do uchwytu. Nastąpiło połączenie BT i po chwili zestawiło połączenie DUN  :ok: :ok: :ok:. Dalej zobaczę, jak to będzie działać z fixem. Ciekaw jestem, jakie będą u Was wyniki instalacji.
Szacunek dla TOMKA666.
Pozdrawiam.


Przy wyznaczonej trasie w drodze urządzenie raz zerwało połączenie DUN.
Po uśpieniu i wybudzeniu (z uruchomioną AM) szybko zestawia połączenia :ok:.
Problem jest tylko z Autostart.exe po włączeniu urządzenia, nie zawsze automatycznie uruchamia się. Jak nie wystartuje, to trzeba uruchomić ręcznie. Dużo czasu zajmuje, jak Autostart.exe wystartuje, zestawienie połączenia DUN po uruchomieniu AM. Moim zdaniem za długo.
Przydałoby się pewniejsze, każdorazowe, uruchomienie Autostartu.
Pozdrawiam.

« Ostatnia zmiana: Październik 11, 2010, 21:54:19 wysłana przez maryszek »
Pozdrawiam
Leszek

Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #33 : Październik 10, 2010, 22:23:46 »
skrypty działają, dzięki Tomek666
U mnie na NR560F ustanowienie połączenia DUN trwa bardzo długo - jakieś 3-4 min od połączenia HFP, znacznie dłużej niż bym zrobił to ręcznie. Czy u innych też jest?
Pojawiło się też kilka problemów. Nie wiem czy to możliwe, ale przestały działać pliki bat. Wcześniej miałem w StartUp plik .bat który kopiował po resecie pliki Miplo w katalogu Windows, a teraz wyskakuje komunikat "There is no application associated with 'MiploKopiuj'. Run the aplication first, than open this file from within the application.". Czy jest możliwe, że skrypt coś blokuje w związku z plikami bat.

Druga sprawa to klawiatura ekranowa. AM uruchamiała mi się z widoczną klawiaturą ekranową i nie można było jej wyłączyć. Ponadto po wejściu do Eksplorera klawiatury nie dało się przesunąć. Odinstalowanie skryptu odblokowało klawiaturę.


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #34 : Październik 11, 2010, 12:19:05 »
U mnie nie ma tych problemów z wyjątkiem czasami długiego połączenia DUN.

Pozdrawiam
Leszek

Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #35 : Październik 11, 2010, 12:29:55 »
korzystasz z plików .bat? Bo dla mnie w chwili obecnej to największy problem i nie wiem, czy to wina skryptu, który zajmuje cmd czy jakiś inny powód.


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #36 : Październik 11, 2010, 16:29:34 »
W MyFlashDisk>Windows>StartUp jest plik *.bat, natomiast w Windowsie nie ma plików miplo. Pisałem na forum, że np. katalog Windows w MyFlashDisk (u mnie) i wpist do Windowsa nie są potrzebne do działania MiploSync. MiploKopiuj nie wiem, czy działo ale MiploSync, MiploLoc są aktywne. Synchronizacja spod AM i CDMMC działa.
Tak naprawdę nie jestem mocny w informatyce.

Pozdrawiam
Leszek

Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #37 : Październik 11, 2010, 19:57:53 »
Bez kopiowania plików Miplo nie będzie działa usługa MiploLoc, tzn. w AM ikonka będzie aktywna ale dane nie będą wysyłane.
maryszek skoro piszesz, że w MyFlashDisk>Windows>StartUp masz plik z rozszerzeniem bat to spróbuj go proszę uruchomić przez eksplorera w Navroadzie.  U mnie po próbie uruchomienia wyskakuje komunikat o błędzie "There is no application associated with..."
a nie powinno się nic pojawiać


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #38 : Październik 11, 2010, 21:45:15 »
"Do mojego autostartu mam skopiowany plik MiploStartup.exe oraz utworzony plik Start.bat. Plik wsadowy Start.bat utworzyłem z taką zawartością:

Kod: [Zaznacz]
copy \MyFlashDisk\Windows\MiploService.dll \Windows\
Po poprawnym wywołaniu tego pliku wsadowego za każdym razem plik MiploService.dll jest kopiowany z \MyFlashDisk\Windows\ do oryginalnego systemowego katalogu urządzenia i za każdym razem po wyłączeniu urządzenia znika z tego oryginalnego katalogu systemowego".

Tak pisał filipmar w wątku "Navroad NR560BF i instalacja MIPLO do AutoMapy".
Ten plik *.bat tak stworzyłem. Po uruchomieniu tego pliku na moment pojawia się jasny ekran i coś tam pisze, chyba po angielsku :(. To jest moment. Może to jest ten wpisany "kod", ale Twojego komunikatu nie widać. Gdzieś czytałem, że rzeczywiście MiploLoc nie działa, ale nie wiem w jakich okolicznościach to było. Na moim koncie w Miplo>MiploLoc nic nie ma. Chyba masz rację, nie działa.

Pozdrawiam
Leszek

Offline Tomek666

  • Newbie
  • Wiadomości: 30
  • Sprzęt: NavRoad 460BT
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #39 : Październik 11, 2010, 21:45:39 »
Poniżej parę uwag i komentarzy do pytań

1) pliki *.bat - mi nigdy nie działały,  może dlatego że w WinCE Core w NavRoad  nie ma programu wiersza poleceń (cmd.exe) :). Właśnie dlatego zainteresowałem się MiploScriptem, który całkowicie wyeliminował potrzebę używania plików *.bat

2) MiploLoc - w skrypcie Autostart.mscr są (zakomentowane) polecenia kopiowania i uruchamiania odpowiednich plików. Można sobie te polecenia dostosować do własnych warunków. U mnie MiploLoc działa.

3) Uruchamianie Autostartu - nigdy nie stwierdziłem takiego problemu, ale skrypt jest wywoływany przez nakładkę NavRoad, a brak jest informacji co do zasad jej funkcjonowania (Proszę się upewnić czy na pewno nie jest uruchomiony proces MortScript.exe). Oczywiście można inaczej wywoływać skrypt, ale jest to bardziej skomplikowane.

4) szybkość uruchamiani DUN. Rzeczywiście różnie to bywa. Próby zestawiania połączenia są powtarzane co 90s. Częściej nie można, bo zdarzają się sytuacje, w której właśnie nawiązane połączenie jest zrywane w celu zestawienia nowego (obserwowałem już proces nawiązywania połączenia trwający ok. 60s).
Proszę przeanalizować plik BTDun.log i zobaczyć za którym razem udaje się zestawić połączenie DUN.

5) Klawiatura ekranowa - nigdy takiego efektu nie zaobserwowałem, nie wiem co może być przyczyną.

Pozdrawiam



Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #40 : Październik 11, 2010, 22:16:06 »
Tomek666
U mnie nie zawsze automatycznie uruchamia się AutoStart.exe. Najdłużej czekałem 10 min. MiploLoc nie wiem czy działa, w Miplo śladu nie ma. Proces MortScript.exe, nie wiem czy jest uruchamiany czy nie. Po zestawieniu DUN w czasie nawigacji zrywało połączenie ok. 2 na 7-8 wyznaczonych tras i powtórnego zestawienia DUN już nie było. Przy ręcznym zestawieniu "Połączenie DUN" zerwania połączenia nie było jak długo używam NR560BF. W ogóle dzięki Ci za włożony trud i pracę w ułatwieniu życia kierowcom.
Pozdrawiam.

Pozdrawiam
Leszek

Offline Jaroslav

  • Clubowicz
  • *
  • Wiadomości: 57
  • Sprzęt: NavRoad Vivo S6
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #41 : Październik 11, 2010, 22:17:13 »
Albo jeśli koniecznie chcesz w oddzielnym pliku, to zamiast "bata" utwórz sobie plik moje_kopiowanie_miplo.mscr  o takiej treści:
If NOT ( DirExists( "\Windows\AppMgr" ))
MkDir( "\Windows\AppMgr" )
Copy( "\SDMMC\Backup\Miplo MiploSync.DAT", "\Windows\AppMgr\Miplo MiploSync.DAT" )
Copy( "\SDMMC\Backup\Miplo MiploSync.DLL", "\Windows\AppMgr\Miplo MiploSync.DLL" )
Copy( "\SDMMC\Backup\miplotoday.dll", "\Windows\miplotoday.dll" )
Copy( "\SDMMC\Backup\MiploService.dll", "\Windows\MiploService.dll" )
EndIf

Wepchnij go do StartUp-u i powino zabanglać  :grin:


Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #42 : Październik 11, 2010, 23:02:07 »
problem z korzystaniem ze skryptu w StartUp-ie jest taki, że wymaga on wczęsniejszego uruchomienia Mort-a


Offline Jaroslav

  • Clubowicz
  • *
  • Wiadomości: 57
  • Sprzęt: NavRoad Vivo S6
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #43 : Październik 11, 2010, 23:52:03 »
Nie wymaga wcześniejszego. Wystarczy jednoczesne:
"\SDMMC\sciezka_dostepu_do_interpretera\MortScript.exe" "\SDMMC\sciezka_dostepu_do_skryptu\moje_kopiowanie_miplo.mscr"


Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #44 : Październik 11, 2010, 23:58:59 »
"\SDMMC\sciezka_dostepu_do_interpretera\MortScript.exe" "\SDMMC\sciezka_dostepu_do_skryptu\moje_kopiowanie_miplo.mscr"


Kolego ale gdzie to wpisać?
domyślam się, że w StartUp-ie, ale do jakiegoś pliku a jeśli tak to z jakim rozszerzeniem?


Offline Jaroslav

  • Clubowicz
  • *
  • Wiadomości: 57
  • Sprzęt: NavRoad Vivo S6
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #45 : Październik 12, 2010, 00:03:19 »
W skróta, Szanowny Kolego, takiego z rozszerzeniem lnk  :)


Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #46 : Październik 12, 2010, 10:34:16 »
dzięki, nie wiedziałem, że w linkach można tak podwójnie wywoływać
jak tylko odżyje mi nawigacja po aktualizacji softu, na razie stanęła na niebieskim ekranie, to spróbuję


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #47 : Październik 14, 2010, 07:41:08 »
Poniżej parę uwag i komentarzy do pytań

2) MiploLoc - w skrypcie Autostart.mscr są (zakomentowane) polecenia kopiowania i uruchamiania odpowiednich plików. Można sobie te polecenia dostosować do własnych warunków. U mnie MiploLoc działa.

Pozdrawiam


1. W informacji o synchronizacji Miplo jest "MiploLoc" aktywne". Czy to znaczy, że działa?
2. Jak sprawdzić działanie MiploLoc, w Miplo jest informacja "Nie zarejestrowano jeszcze żadanej
    lokalizacji dla Twojego pojazdu."
3. Jeżeli nie działa, to jak uruchomić tę opcję?

Pozdrawiam
Leszek

Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #48 : Październik 14, 2010, 22:58:07 »
Do działania MiploLoc koniecznie są następujące pliki w następujących katalogach:
\Windows\AppMgr\Miplo MiploSync.dat
\Windows\AppMgr\Miplo MiploSync.dll
\Windows\miplotoday.dll
\Windows\MiploService.dll
pliki te za każdym restartem kasują się, więc potrzebny jest skrypt, który będzie je powtórnie kopiował na swoje miejsce

2) MiploLoc - w skrypcie Autostart.mscr są (zakomentowane) polecenia kopiowania i uruchamiania odpowiednich plików. Można sobie te polecenia dostosować do własnych warunków. U mnie MiploLoc działa.


przeglądałem zawartość Autostart.mscr  i ja tam nie widzę poleceń, które miałyby kopiować powyższe pliki - przynajmniej tak mi się wydaje,

Jeśli w AM -> Menu -> Poi -> MiploLoc jest włączone a położenie nie jest rejestrowane to znaczy, że nie masz powyższych plików.

Tomek666 może działać, bo nie restartował urządzenia po instalacji MiploSync.



Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #49 : Październik 15, 2010, 07:01:41 »
Poczekam, może ktoś wymyśli, jak te pliki tam wsadzić. Rzeczywiście po instalacji MS w domyślnej lokalizacji pliki są wpisywane, ale po restarcie ich nie ma. Trudno.
Pozdrawiam.

Pozdrawiam
Leszek

Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #50 : Październik 15, 2010, 09:36:29 »
Kolega Jaroslav  kilka postów wyżej napisał jak ten problem rozwiązać skryptem.


Offline angler22

  • Redaktor
  • Moderator
  • *****
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #51 : Październik 15, 2010, 09:58:04 »
Do działania MiploLoc koniecznie są następujące pliki w następujących katalogach:
\Windows\AppMgr\Miplo MiploSync.dat
\Windows\AppMgr\Miplo MiploSync.dll
\Windows\miplotoday.dll
\Windows\MiploService.dll

Z listy na pewno darować sobie można Miplotoday, bo on odpowiada tylko za skróty ekranowe w WM (na PDA).
Z doświadczeń jednego z Użytkowników mojego skryptu "automatyzacji" DUN wynikało by, że kluczowym plikiem jest Miploservice i to moim zdaniem ma sens. W takim przypadku zamiast kopiować wszystkie powyższe pliki do \Windows\, można zastosować metodę rejestrową, czyli zmieniając odpowiednie wpisy w:
HKEY_LOCAL_MACHINE\Services\MiploService gdzie wpis Dll o wartości "miplosync.dll" zastępujemy pełną ścieżką do lokalizacji dll'ki (jakaś trwała lokalizacja typu residentflash, shell disk czy jak to się tam u Was zwie, czyli np. \Shell\miplosync.dll). Być może tyle i tylko tyle wystarczy! Możecie spróbować w każdym razie.


Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #52 : Październik 15, 2010, 10:51:50 »
można potestować, MiploLoc działa nawet jak się stoi w miejscu, tylko fixa trzeba złapać
ja na razie nie mam na czym testować bo moja navi pojechała do serwisu


Offline angler22

  • Redaktor
  • Moderator
  • *****
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #53 : Październik 15, 2010, 13:21:21 »
Wiem, że działa, ale skończyły mi się tanie pakiety GPRS w komórce :) Dlatego szukam testerów.


Offline luckynyc

  • Clubowicz
  • **
  • Wiadomości: 236
  • Sprzęt: Asus A696, Navroad NR560BF
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #54 : Październik 15, 2010, 13:26:48 »
potencjalnie wystarcza net przez AS i złapany fix
ja mam duży darmowy pakiet GPRS ale nie mam urządzenia :)


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #55 : Październik 15, 2010, 19:12:44 »
angler22
"HKEY_LOCAL_MACHINE\Services\MiploService gdzie wpis Dll o wartości "miplosync.dll" zastępujemy pełną ścieżką do lokalizacji dll'ki (jakaś trwała lokalizacja typu residentflash, shell disk czy jak to się tam u Was zwie, czyli np. \Shell\miplosync.dll). Być może tyle i tylko tyle wystarczy! Możecie spróbować w każdym razie."

To nie działa. W rejestrze HKEY_LOCAL_MACHINE\Services\MiploService nie ma wartości "miplosync.dll" . Jest tylko wszędzie "MiploService". Wpisywałem tak i inaczej bez rezultatu. Ciekawe, że raz udało się rano wysłać lokalizację po ręcznym wpisaniu czterech plików, można sprawdzić na Miplo, ale powtórzyć tego wieczorem już się nie udało. Będę dalej na razie ręcznie wpisywać i zobaczę czy się uda.

Połączone: [time]Październik 15, 2010, 19:49:27[/time]
Wysłanie lokalizacji udało się (po skopiowaniu plików) gdy ręcznie uruchomiłem MiploSartUp.exe.
Otworzyłem Windows>StartUp>MyFlashDisk>Windows>StartUp> i tu nie ma pliku MiploStartUp.exe. Chyba powinien być.

« Ostatnia zmiana: Październik 15, 2010, 19:59:19 wysłana przez maryszek »
Pozdrawiam
Leszek

Offline angler22

  • Redaktor
  • Moderator
  • *****
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #56 : Październik 15, 2010, 19:57:13 »
To nie działa. W rejestrze HKEY_LOCAL_MACHINE\Services\MiploService nie ma wartości "miplosync.dll" . Jest tylko wszędzie "MiploService". Wpisywałem tak i inaczej bez rezultatu. Ciekawe, że raz udało się rano wysłać lokalizację po ręcznym wpisaniu czterech plików, można sprawdzić na Miplo, ale powtórzyć tego wieczorem już się nie udało. Będę dalej na razie ręcznie wpisywać i zobaczę czy się uda.

Poważnie nie ma? Bardzo dziwne - nawet tuż po instalacji? U mnie cały ten klucz wygląda tak :
[HKEY_LOCAL_MACHINE\Services\MiploService]
"Context"=dword:00000000
"Description"="MiploSync Service"
"DisplayName"="MiploSync Service"
"Dll"="MiploService.dll"
"Index"=dword:00000000
"Keep"=dword:00000001
"Order"=dword:00000008
"Prefix"="MIP"
"UnsignedService"=dword:00000001
To wersja czysta (po instalacji). Zmiany oczywiście trzeba by dokonać w "DLL"="MiploService.dll".
Jednak kopiowanie plików też jest dobrą metodą (taką właśnie stosowałem w skrypcie uruchamiającym Miploloc dla Blow 50YBT). O tej zmianie wpisów tak tylko wspomniałem, jako o ciekawostce.


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #57 : Październik 15, 2010, 20:19:07 »
angler22 zerknij na dopisek wyżej,

u mnie jest tak jak u Ciebie:

"Context"=dword:0
"Description"="MiploSync Service"
"DisplayName"="MiploSync Service"
"Dll"="MiploService.dll"
"Index"=dword:0
"Keep"=dword:1
"Order"=dword:8
"Prefix"="MIP"
"UnsignedService"=dword:1

ale wpisywanie w DLL w miejsce MiploService.dll ścieżki do miplosync.dll nic nie daje (\MyFlashDisk\Windows\AppMgr\Miplo MiploSync.dll). Może trzeba dopisać?

Pozdrawiam
Leszek

Offline angler22

  • Redaktor
  • Moderator
  • *****
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #58 : Październik 15, 2010, 20:34:10 »
Nie tak! To ścieżka do MiploService.dll a nie do MiploSync.dll Po tym co wpisałeś wnioskuję, że u Ciebie będzie to wyglądało tak:
"Dll"="\MyFlashDisk\Windows\MiploService.dll"
Na razie to sprawdzamy.


Offline maryszek

  • Clubowicz
  • ***
  • Wiadomości: 326
  • Sprzęt: S. GALAXY S5 Neo+aAMPL
Odp: Automatyczne zestawianie połączenia DUN
« Odpowiedź #59 : Październik 15, 2010, 20:54:16 »
Dokładnie tak wpisałem w pierwszej wersji. Bez rezultatu. Później wpisywałem inaczej i nic bo było błędnie. Zadziałało (po skopiowaniu plików) gdy ręcznie uruchomiłem MiploSartUp.exe.

« Ostatnia zmiana: Październik 15, 2010, 21:04:36 wysłana przez maryszek »
Pozdrawiam
Leszek