Autor Wątek: GPS działa albo nie działa?  (Przeczytany 18694 razy)

0 Użytkowników i 1 Gość przegląda ten wątek.

Offline drogi

  • Clubowicz
  • ***
  • Wiadomości: 277
  • Sprzęt: HTC Diamond, Samsung I5700
GPS działa albo nie działa?
« : Maj 21, 2006, 16:32:24 »
Witam,
Od wczoraj jestem posiadaczem A636, mam mały problem z GPS zainstalowałem VisualGPSce i nie pokazuje zadnych satelit, chodziłem wszędzie (na zewnątrz) i nic. Dioda zielona miga, ustawienia zmienialem bezskutecznie. Wydawalo mi się że coś jest ze sprzętem lecz w samochodzie zdziwił mnie pewien fakt, otóż nadal nic nie wykrywa, żadnych satelit lecz jak przejde do zakładki Panel  gdzie są wskażniki szybkości itp to one podczas jazdy działają, jak to możliwe? co zrobiłem źle że nie widze żadnych staelit w "słupkach"?

AM Demo rónież nie wykrywa sygnału GPS.

Z góry dziękuje za porady.


PDAclub.pl

GPS działa albo nie działa?
« : Maj 21, 2006, 16:32:24 »
R E K L A M A:


Pablo2525

  • Gość
GPS działa albo nie działa?
« Odpowiedź #1 : Maj 21, 2006, 20:25:48 »
W Asusie wchodzisz w Start/Ustawienia/System/GPS, w pierwszej zakładce (Programy) ustaw COM5, w drugiej (Sprzęt) ustaw COM4 i szybkość 4800, w trzeciej ptaszek przy zarządzaniu GPS obowiązkowy   :lol:


Offline drogi

  • Clubowicz
  • ***
  • Wiadomości: 277
  • Sprzęt: HTC Diamond, Samsung I5700
GPS działa albo nie działa?
« Odpowiedź #2 : Maj 22, 2006, 19:35:21 »
Te ustawienia oczywiście zmieniałem na różne sposoby podawane na forum, to które podałeś nic nie zmiania również.

Tu kwestia nie jest że nie działa tylko jak działa, tak jak pisałem VisualGPSce pokazuje predkość jak się jedzie  itd (wiec złapał sygnał skoro te dane działają), nie pokazuje tylko położenia ani żadnego sygnału staelity.

Troszke z tym się męcze i wgrałem jeszcze program GPS Tuner i on działa, tzn znajduje połączenie i fixa.
Czy komuś działa program VisualGPSce (ver. 1.00.3) na a636?


Offline angler22

  • Redaktor
  • Clubowicz
  • ******
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
GPS działa albo nie działa?
« Odpowiedź #3 : Maj 22, 2006, 20:15:48 »
Cytat: "drogi"
Te ustawienia oczywiście zmieniałem na różne sposoby podawane na forum, to które podałeś nic nie zmiania również.

Tu kwestia nie jest że nie działa tylko jak działa, tak jak pisałem VisualGPSce pokazuje predkość jak się jedzie  itd (wiec złapał sygnał skoro te dane działają), nie pokazuje tylko położenia ani żadnego sygnału staelity.

Troszke z tym się męcze i wgrałem jeszcze program GPS Tuner i on działa, tzn znajduje połączenie i fixa.
Czy komuś działa program VisualGPSce (ver. 1.00.3) na a636?


Mnie to wygląda na "ubogi" protokół NMEA - pewnie jakimś cudem wyłączyły Ci się sekwencje GSV i GSA (wtedy nie "widać" satelitów) oraz GPRMC - wtedy VisualGps nie ma fixa. Nadaje za to np sekwencja VTG - odpowiedzialna za prędkość. Przełącz gps'a na pełne NMEA programem Cemonitor (zwany też winfast Cemonitor).
Jeszcze link do programu ftp://ftp.leadtek.com.tw/gps/Tools/WinCEMonitor.zip


Offline drogi

  • Clubowicz
  • ***
  • Wiadomości: 277
  • Sprzęt: HTC Diamond, Samsung I5700
GPS działa albo nie działa?
« Odpowiedź #4 : Maj 23, 2006, 08:22:52 »
Cytat: "angler22"
Mnie to wygląda na "ubogi" protokół NMEA - pewnie jakimś cudem wyłączyły Ci się sekwencje GSV i GSA (wtedy nie "widać" satelitów) oraz GPRMC - wtedy VisualGps nie ma fixa. Nadaje za to np sekwencja VTG - odpowiedzialna za prędkość. Przełącz gps'a na pełne NMEA programem Cemonitor (zwany też winfast Cemonitor).
Jeszcze link do programu ftp://ftp.leadtek.com.tw/gps/Tools/WinCEMonitor.zip



Zainstalowałem ten program, jak ustawie GPS Protocol na SiRF to po chwili ten program łapie położenie, satelity i Fixa. Ustawiajac na NMEA nic sie nie dzialo przez dlugi czas, mieszalem az w koncu zlapalem cos na tym NMEA. Sprawdzajac od racu program VisualGPSce widzialem satelity, zlapalem fixa, Demo AM rowniez zadzialalo (choc nie pokazalo na mapie bo mam tylko bialystok ;) ).
Problem jednak zaczal sie dalej, wylaczylem wszystko i chcialem zalaczyc od nowa, niestety nie doszedlem juz do tego co opisalem wyzej. Na protokole SiRF lapie wszystko (tylko program Cemonitor) inne nie dzialaja. Co gorsza gdy zmienie na NMEA po jakis 1 minucie program wylacza sie, albo sie wiesza (robilem HS nic nie pomoglo).
Jakie powinny byc ustawienia w Cemonitor?

ja mam w port setings:  Port: Com5;  BaudRate: 4800
w command:
dla NMEA:  BaudRate: 4800
                GGA: 1
                GLL: 0
                GSA: 5
                GSV: 5
                RMC: 1
                VTG: 1
                MSS: 0
dla SiRF:   BaudRate: 38400
               Data Bit: 8  (nieaktywne)
               Stop Bit: 1  (nieaktywne)
               Parity: N  (nieaktywne)

czy AM i VisualGPSce działa tylko na NMEA?
czy ustawienia w Cemonitor odnosza sie do calego sys.GPS, inaczej mowiac jak cos zmienie to ma to wplyw na wszystkie programy kozystajace GPS?
co moge dalej zrobić?


Offline angler22

  • Redaktor
  • Clubowicz
  • ******
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
GPS działa albo nie działa?
« Odpowiedź #5 : Maj 23, 2006, 09:25:05 »
Cytat: "drogi"
Zainstalowałem ten program, jak ustawie GPS Protocol na SiRF to po chwili ten program łapie położenie, satelity i Fixa. Ustawiajac na NMEA nic sie nie dzialo przez dlugi czas, mieszalem az w koncu zlapalem cos na tym NMEA. Sprawdzajac od racu program VisualGPSce widzialem satelity, zlapalem fixa, Demo AM rowniez zadzialalo (choc nie pokazalo na mapie bo mam tylko bialystok ;) ).
Problem jednak zaczal sie dalej, wylaczylem wszystko i chcialem zalaczyc od nowa, niestety nie doszedlem juz do tego co opisalem wyzej. Na protokole SiRF lapie wszystko (tylko program Cemonitor) inne nie dzialaja. Co gorsza gdy zmienie na NMEA po jakis 1 minucie program wylacza sie, albo sie wiesza (robilem HS nic nie pomoglo).
Jakie powinny byc ustawienia w Cemonitor?

ja mam w port setings:  Port: Com5;  BaudRate: 4800
w command:
dla NMEA:  BaudRate: 4800
                GGA: 1
                GLL: 0
                GSA: 5
                GSV: 5
                RMC: 1
                VTG: 1
                MSS: 0
dla SiRF:   BaudRate: 38400
               Data Bit: 8  (nieaktywne)
               Stop Bit: 1  (nieaktywne)
               Parity: N  (nieaktywne)

czy AM i VisualGPSce działa tylko na NMEA?
czy ustawienia w Cemonitor odnosza sie do calego sys.GPS, inaczej mowiac jak cos zmienie to ma to wplyw na wszystkie programy kozystajace GPS?
co moge dalej zrobić?


Ważne że widać jakiś efekt :) Po kolei :
Automapa i 99% innych programów działa WYŁĄCZNIE na protokole NMEA
i taki też protokół musisz ustawić.
Najważniejsze sekwencje w tym protokole to GGA, VTG, RMC, GSV i GSA. W Cemonitorze powinieneś je ustawić tak:
GGA: 1
GLL: 1
GSA: 1 (może być też 5)
GSV: 5
RMC: 1
VTG: 1
MSS: 0
i baud 4800
Po takim ustawieniu powinieneś zamknąć cemonitora (całkiem zamknąć - nie schować) i spróbować odpalić GPSinfo.
Acha - tylko pamiętaj, że przy ustanawianiu połączenia w Cemonitor MUSISZ na początku podać parametry z jakimi działa w danej chwili odbiornik! Czyli jak poprzednio przestawiłeś go na SIrf to i przy połączeniu najpierw musisz podać Sirf i prędkość 38400 (czy jaką tam ustawiłeś). Dopiero jak w głównym ekranie zaczniesz widzieć po połączeniu z GPS jakieś dane (nawet zera - byle by były) i biegnący czas, dopiero wtedy możesz programować na NMEA wg. powyższych wskazówek.


Offline drogi

  • Clubowicz
  • ***
  • Wiadomości: 277
  • Sprzęt: HTC Diamond, Samsung I5700
GPS działa albo nie działa?
« Odpowiedź #6 : Maj 23, 2006, 17:25:40 »
Wielkie dzięki angler22 za pomoc, zaczeło wszystko działac i dziala jak na razie caly czas (juz nie mieszam w Cemonitor) najbardzie pomogło chyba Twoje "Acha".
Dziwi mnie strasznie to ze po zakupie urzadzenia nie bylo ono na tyle dograne aby wgrac jakas mape i to wszystko, co zrobilby ktos kto nie moglby zapytac sie na forum ;)
Takie ostatnie pytanko czy np po HS lub wgraniu nowego roma trzeba bedzie znow to ustawiac, czy te ustawienia sa na poziomie sprzetowej?

Jeszcze raz wielkie dzieki angler22 za pomoc i rozpisanie rozwiazania problemu.


Offline angler22

  • Redaktor
  • Clubowicz
  • ******
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
GPS działa albo nie działa?
« Odpowiedź #7 : Maj 23, 2006, 20:25:49 »
Cytat: "drogi"
Wielkie dzięki angler22 za pomoc, zaczeło wszystko działac i dziala jak na razie caly czas (juz nie mieszam w Cemonitor) najbardzie pomogło chyba Twoje "Acha".
Dziwi mnie strasznie to ze po zakupie urzadzenia nie bylo ono na tyle dograne aby wgrac jakas mape i to wszystko, co zrobilby ktos kto nie moglby zapytac sie na forum ;)
Takie ostatnie pytanko czy np po HS lub wgraniu nowego roma trzeba bedzie znow to ustawiac, czy te ustawienia sa na poziomie sprzetowej?

Jeszcze raz wielkie dzieki angler22 za pomoc i rozpisanie rozwiazania problemu.


Niestety nie miałem przyjemności bawić się tym sprzętem, dlatego nie wiem, jak zazwyczaj jest ustawione, ale faktycznie ubogi protokół NMEA ustawiony fabrycznie może sprawiać problemy mniej doświadczonym użytkownikom. Co do drugiej części wypowiedzi - zazwyczaj GPS ma swoją własną bateryjkę podtrzymującą pamięć i resetowanie palmtopa nie ma wpływu na ustawienia GPS'u. To co zaprogramowałeś powinno się utrzymać. Rozumiem że HS miało oznaczać HR Hard Reset :) . Co do wgrywania romu - tu już nie jestem pewien, ale swego czasu była mowa o wgrywaniu jakiegoś firmware'u GPS do Mio 168 i był to zupełnie inny proces, nie związany z wymianą romu głównego. Zatem zmiana samego romu (systemu operacyjnego) chyba nie wpłynie na GPS. Zresztą czym się martwić Cemonitor ma 70 kb i jest na tyle prosty w obsłudze, że zawsze warto mieć go gdzieś w archiwum na PPC w razie kłopotów.


Offline b98

  • Clubowicz
  • ****
  • Wiadomości: 541
GPS działa albo nie działa?
« Odpowiedź #8 : Maj 23, 2006, 21:04:51 »
widzę, że kolega jest mocno w temacie ... może jakaś mała optymalizacja nastaw fabrycznych dla N560  :?:  :roll:


Offline :DARECKI

  • Newbie
  • Wiadomości: 5
GPS działa albo nie działa?
« Odpowiedź #9 : Maj 24, 2006, 06:54:58 »
Witam
Mam wydaje mi się że podobny problem to znaczy próbowałem wyłączyć Static Navigation programem Aplsirf - przełączylem z nmea na sirf i ... to był ostatni raz kiedy dostałem jakieś dane z gps :(
stan obecny wygląda tak GPs ustawiony na com 5 dla urządzeń com 4 i 4800 uruchamiam visualgps i poza migającą diodą nic. Z poziomu aplsirf nia mogę zmienić na NMEA czy tym programem Cemonitor uda się to przywrócić ( soft reset nie pomaga, hard reset też nie i zostaje mi jeszcze przywrócenie fabrycznych ustawień - ale tu kłania się instalacja romu)


Offline angler22

  • Redaktor
  • Clubowicz
  • ******
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
GPS działa albo nie działa?
« Odpowiedź #10 : Maj 24, 2006, 09:01:50 »
Cytat: ":DARECKI"
Witam
Mam wydaje mi się że podobny problem to znaczy próbowałem wyłączyć Static Navigation programem Aplsirf - przełączylem z nmea na sirf i ... to był ostatni raz kiedy dostałem jakieś dane z gps :(
stan obecny wygląda tak GPs ustawiony na com 5 dla urządzeń com 4 i 4800 uruchamiam visualgps i poza migającą diodą nic. Z poziomu aplsirf nia mogę zmienić na NMEA czy tym programem Cemonitor uda się to przywrócić ( soft reset nie pomaga, hard reset też nie i zostaje mi jeszcze przywrócenie fabrycznych ustawień - ale tu kłania się instalacja romu)


Tak - Cemonitor powinien rozwiązać problem. Przeczytaj dokładnie mój poprzedni post (6 od góry) i szczególnie zwróć uwagę na część po Acha :) - jak wspomiał Drogi - to kluczowa sprawa, na którą nie wszyscy zwracają uwagę. Jak sobie nie poradzisz pisz .


Offline angler22

  • Redaktor
  • Clubowicz
  • ******
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
GPS działa albo nie działa?
« Odpowiedź #11 : Maj 24, 2006, 09:07:52 »
Cytat: "b98"
widzę, że kolega jest mocno w temacie ... może jakaś mała optymalizacja nastaw fabrycznych dla N560  :?:  :roll:


Większość gps'ów ma standardowo (fabrycznie) ustawione to co trzeba (pełny NMEA) i nic nie trzeba w nich zmieniać. Można ewentualnie zmienić częstotliwość nadawania sekwencji GSA i GSV by mieć częstsze (niż co 5 sekund) informacje o dostępności satelitów, ale może to mieć również wpływ na większe "zamulenie" wolnych PPC, bo liczba danych na sekundę wzrasta znacznie.


Offline drogi

  • Clubowicz
  • ***
  • Wiadomości: 277
  • Sprzęt: HTC Diamond, Samsung I5700
GPS działa albo nie działa?
« Odpowiedź #12 : Maj 24, 2006, 11:24:36 »
Nachodzi mnie takie pytanie w jakim celu jest ten drugi tryb SiRF skoro jak już było wspominane wcześniej 99% programów działa na NMEA? (wiem można powiedzieć że właśnie jest dla tego 1% programów ale takie "usprawiedliwienie" jakoś mnie nie przekonuje.[/url]


Offline angler22

  • Redaktor
  • Clubowicz
  • ******
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
GPS działa albo nie działa?
« Odpowiedź #13 : Maj 24, 2006, 14:03:03 »
Cytat: "drogi"
Nachodzi mnie takie pytanie w jakim celu jest ten drugi tryb SiRF skoro jak już było wspominane wcześniej 99% programów działa na NMEA? (wiem można powiedzieć że właśnie jest dla tego 1% programów ale takie "usprawiedliwienie" jakoś mnie nie przekonuje.[/url]


NMEA jest starszym standardem i po prostu przyjął się w większości aplikacji nawigacyjnych. Sirf wprowadzono później - gdzieś czytałem, że umożliwia on nieco większą oszczędność energi, bo wysyła informacje szybciej (do 115Kb/sek) w stosunku do NMEA (4,8Kb/sek) i po przesłaniu danych może przełączać się w jakiś tryb oszczędnościowy. Nie wiem na ile była to wiarygodna informacja - trzeba by spytać Moi, na pewno będzie wiedział coś więcej na ten temat. A co do różnych standardów - to przecież normalne w dzisiejszym świecie, że każdy chce mieć swój "standard". Patrz choćby karty MS (sony), minidisc, czy płyty DVD
-R i +R :)


Offline :DARECKI

  • Newbie
  • Wiadomości: 5
GPS działa albo nie działa?
« Odpowiedź #14 : Maj 25, 2006, 08:26:50 »
dziękie angler22 - uruchomiłem gpsa
Atak swoją drogą to gdzie można się dowiedzieć czegoś na temet mea i sirf


Offline angler22

  • Redaktor
  • Clubowicz
  • ******
  • Wiadomości: 4782
  • Sprzęt: Blow 50YBT, Goclever 5010, Wayteq X960, AM XL
GPS działa albo nie działa?
« Odpowiedź #15 : Maj 25, 2006, 13:02:45 »
Cytat: ":DARECKI"
dziękie angler22 - uruchomiłem gpsa
Atak swoją drogą to gdzie można się dowiedzieć czegoś na temet mea i sirf


Na temat samego systemu GPS przeczytaj świetny materiał, przygotowany przez Moi http://www.pdaclub.pl/forum/viewtopic.php?t=30868&highlight=almanach . A o sentencjach NMEA - może to : http://www.pocketgpsworld.com/winfastnavigatorppc.php


Offline teodoor

  • Newbie
  • Wiadomości: 5
A636N tom tom 6.010 nie moze zlapac sygnalu
« Odpowiedź #16 : Styczeń 27, 2007, 22:13:24 »
witam,...zrobilem jak poradziliscie czyli ...com 3 i 5 oraz 4800 oraz ptaszek przy automatycznym zarzadzaniu GPS i ... nadal nic sie nie dzieje

Dodam ze w programie TOM TOM mam ustawione w STANACH GPS urzadzenie na INNE NMEA GPS (odbiornik jaki wydaje mi sie powinien byc ustawiony).Ustawiajac ten odbiornik podaje sie szybkosc transmisji (4800) oraz COMy (probowalem na 3 i 5 ).

I nic ..wciaz laczy ..poznij zrywa i znowusz laczy..hmmm

Zainstalowalem tez program visualgps i na nim pieknie (po ustawienu na COM 5) znalazl 12 satelit. Łapie je szybciotko.

Nie wiem co dalej robic...?


Offline teodoor

  • Newbie
  • Wiadomości: 5
GPS działa albo nie działa?
« Odpowiedź #17 : Styczeń 27, 2007, 22:25:21 »
dodam tylko bo temat mojego powyzszego wpisu jest malo widoczny ....ze moj problem dotyczy ... kupilem A636N i tom tom 6.010 nie moze zlapac sygnalu


Offline b707

  • Clubowicz
  • **
  • Wiadomości: 211
GPS działa albo nie działa?
« Odpowiedź #18 : Styczeń 28, 2007, 00:02:06 »
Cytat: "teodoor"
dodam tylko bo temat mojego powyzszego wpisu jest malo widoczny ....ze moj problem dotyczy ... kupilem A636N i tom tom 6.010 nie moze zlapac sygnalu



Odpalasz tylko tom toma czy cos innego opartego na GPS chodzi w tle?

Generalnie GPS nadaje na porcie COM 5, gdy którys program korzysta z tego portu bezposrednio to inne sa blokowane. Aby temu zapobiec korzysta się ze splittera GPS który jest w WM 5.0. Dlatego w zakładce sprzet musi byc COM 5 i 4800 [informuje to system skad pobierac dane GPS]. Natomiast w programy ustawiasz wolny port GPS... Niewiem czy na COM 3 cos nie siedzi... Ustaw tam lepiej COM 9... [zakładka programy pokazuje systemowi gdzie ma wysyłac dane GPS ze sprzetu i rozdzielać je] Ptaszek w automatycznym rozdzielaniu musi być.

Teraz wszystkie programy nawigacyje powinny korzystac z portu COM 9... Niektóre uparcie korzsyatja z 5 i sie nawzajem blokuja, więc je przestawiamy. Transmisja na 4800 wsytarczy.

Jak nie pomoże zrób inaczej. W zakładce sprzet wybierz <brak> a w programy ustaw COM 5. Teraz w Tom Tom wybierz Com 5/4800 działac może tylko tom tom... Visual GPSce musi być wyłączony. Jezeli to nie pooże to wina musi siedziec w ustawianiech GPS w TT... Ale to nie pomoge bo Tom Toma niemam :/


Offline teodoor

  • Newbie
  • Wiadomości: 5
GPS działa albo nie działa?
« Odpowiedź #19 : Styczeń 28, 2007, 19:35:40 »
hi.
 poprobowalem z comami ale nici ... wiec zabralem sie za program. Poustawialem w ustawieniach 3, 5 i 4800 i odinstalowalem TT ... nastepnie ponownie zainstalowalem i .... po klopocie :) dziala
dziekuje za wsparcie pozdr


Offline teodoor

  • Newbie
  • Wiadomości: 5
GPS działa albo nie działa?
« Odpowiedź #20 : Styczeń 31, 2007, 19:34:05 »
witam.....kolejny zong i kolejny help .... a wiec program TT dziala...teraz chcialbym aby program zauwazyl nowe mapki i nie wiem gdzie je skopiowac.
W programie TT nie mam zadnej opcji przeszukiwania dysku...jest tylko opcja przelaczenia mapy..lecz to miedzy juz widzianymi przez program.
hmmm z wielkosci map moge sie domyslic ze te mapy powinienem zrzucic na karte SD lecz jak TT ma je zobaczyc ? ??


Offline b707

  • Clubowicz
  • **
  • Wiadomości: 211
GPS działa albo nie działa?
« Odpowiedź #21 : Styczeń 31, 2007, 21:07:11 »
To pytanie to juz do działu TomToma daj bo tutaj moze pozostac niezauważone
pzdr


Offline orionek

  • Newbie
  • Wiadomości: 23
  • Sprzęt: htc diamond
Odp: GPS działa albo nie działa?
« Odpowiedź #22 : Lipiec 16, 2007, 21:24:53 »
Cytat: drogi
Zainstalowałem ten program, jak ustawie GPS Protocol na SiRF to po chwili ten program łapie położenie, satelity i Fixa. Ustawiajac na NMEA nic sie nie dzialo przez dlugi czas, mieszalem az w koncu zlapalem cos na tym NMEA. Sprawdzajac od racu program VisualGPSce widzialem satelity, zlapalem fixa, Demo AM rowniez zadzialalo (choc nie pokazalo na mapie bo mam tylko bialystok ;) ).
Problem jednak zaczal sie dalej, wylaczylem wszystko i chcialem zalaczyc od nowa, niestety nie doszedlem juz do tego co opisalem wyzej. Na protokole SiRF lapie wszystko (tylko program Cemonitor) inne nie dzialaja. Co gorsza gdy zmienie na NMEA po jakis 1 minucie program wylacza sie, albo sie wiesza (robilem HS nic nie pomoglo).
Jakie powinny byc ustawienia w Cemonitor?

ja mam w port setings:  Port: Com5;  BaudRate: 4800
w command:
dla NMEA:  BaudRate: 4800
                GGA: 1
                GLL: 0
                GSA: 5
                GSV: 5
                RMC: 1
                VTG: 1
                MSS: 0
dla SiRF:   BaudRate: 38400
               Data Bit: 8  (nieaktywne)
               Stop Bit: 1  (nieaktywne)
               Parity: N  (nieaktywne)

czy AM i VisualGPSce działa tylko na NMEA?
czy ustawienia w Cemonitor odnosza sie do calego sys.GPS, inaczej mowiac jak cos zmienie to ma to wplyw na wszystkie programy kozystajace GPS?
co moge dalej zrobić?

Ważne że widać jakiś efekt :) Po kolei :
Automapa i 99% innych programów działa WYŁĄCZNIE na protokole NMEA
i taki też protokół musisz ustawić.
Najważniejsze sekwencje w tym protokole to GGA, VTG, RMC, GSV i GSA. W Cemonitorze powinieneś je ustawić tak:
GGA: 1
GLL: 1
GSA: 1 (może być też 5)
GSV: 5
RMC: 1
VTG: 1
MSS: 0
i baud 4800
Po takim ustawieniu powinieneś zamknąć cemonitora (całkiem zamknąć - nie schować) i spróbować odpalić GPSinfo.
Acha - tylko pamiętaj, że przy ustanawianiu połączenia w Cemonitor MUSISZ na początku podać parametry z jakimi działa w danej chwili odbiornik! Czyli jak poprzednio przestawiłeś go na SIrf to i przy połączeniu najpierw musisz podać Sirf i prędkość 38400 (czy jaką tam ustawiłeś). Dopiero jak w głównym ekranie zaczniesz widzieć po połączeniu z GPS jakieś dane (nawet zera - byle by były) i biegnący czas, dopiero wtedy możesz programować na NMEA wg. powyższych wskazówek.


Witam
Poustawiałem to dokładnie tak jak opisałeś i w moim przypadku dalej nic nawet w visualGPS nie łapie fix'a :( mam asus'a a696 w ustawieniach GPS mam soft na com5 sprzet na brak bitrate na 4800


Offline McMike

  • Clubowicz
  • *****
  • Wiadomości: 1585
  • McMike
  • Sprzęt: E90, Asus A639, AM 4.1 + S8 i octa
Odp: GPS działa albo nie działa?
« Odpowiedź #23 : Lipiec 17, 2007, 01:29:51 »
(....)Witam
Poustawiałem to dokładnie tak jak opisałeś i w moim przypadku dalej nic nawet w visualGPS nie łapie fix'a :( mam asus'a a696 w ustawieniach GPS mam soft na com5 sprzet na brak bitrate na 4800

Ale jesteś na zewnątrz domu, a nie w pokoju, albo na balkonie?;)

Rząd nic nie robi i to się najbardziej chyba Polakom podoba =)

Offline orionek

  • Newbie
  • Wiadomości: 23
  • Sprzęt: htc diamond
Odp: GPS działa albo nie działa?
« Odpowiedź #24 : Lipiec 17, 2007, 15:36:01 »
(....)Witam
Poustawiałem to dokładnie tak jak opisałeś i w moim przypadku dalej nic nawet w visualGPS nie łapie fix'a :( mam asus'a a696 w ustawieniach GPS mam soft na com5 sprzet na brak bitrate na 4800

Ale jesteś na zewnątrz domu, a nie w pokoju, albo na balkonie?;)


Siedziałem na dworze przez dobre 2 godziny na otwartej przestrzeni i nic :( tylko dioda zielona miga a GPSa nie może znaleźć żaden program. Zanim sie to stało miałem włączonego tom tom'a i robiło sie coś takiego że GPSa wykrył i za chwile go nie było i znów sie pokazał... i tak ze 3 razy i później już nie udało sie uruchomić na żadnym programie. Robiłem już HR i nici. Chyba pojade jednak oddać do serwisu.

Pozdrawiam
Orion


Offline drogi

  • Clubowicz
  • ***
  • Wiadomości: 277
  • Sprzęt: HTC Diamond, Samsung I5700
Odp: GPS działa albo nie działa?
« Odpowiedź #25 : Lipiec 17, 2007, 19:55:27 »
(....)Witam
Poustawiałem to dokładnie tak jak opisałeś i w moim przypadku dalej nic nawet w visualGPS nie łapie fix'a :( mam asus'a a696 w ustawieniach GPS mam soft na com5 sprzet na brak bitrate na 4800

Ale jesteś na zewnątrz domu, a nie w pokoju, albo na balkonie?;)


Siedziałem na dworze przez dobre 2 godziny na otwartej przestrzeni i nic :( tylko dioda zielona miga a GPSa nie może znaleźć żaden program. Zanim sie to stało miałem włączonego tom tom'a i robiło sie coś takiego że GPSa wykrył i za chwile go nie było i znów sie pokazał... i tak ze 3 razy i później już nie udało sie uruchomić na żadnym programie. Robiłem już HR i nici. Chyba pojade jednak oddać do serwisu.

Pozdrawiam
Orion


Miałem podobnie ostatnio, statusy poszczególnych statelit były widoczne natomiast nie łapał fixa - HR nie pomógł, po wysłaniu do serwisu wymienili Antenę GPS (przy okazji wymieniając płytę główną i ekran LCD :) )


Offline Rigel

  • Newbie
  • Wiadomości: 9
Odp: GPS działa albo nie działa?
« Odpowiedź #26 : Listopad 10, 2008, 20:36:26 »
witam  :D dzięki   temu wątkowi udało mi sie asusa zreperować, cos mi sie stło i tylko działał IGO a Automapa nie chciała. a teraz wszystko smiga  :ok pomijając fakt ze automapa strasznie długo szuka sygnału, ale przynajmniej smiga.


Offline stanley_p

  • Clubowicz
  • **
  • Wiadomości: 234
  • Sprzęt: Asus A696, 16GB SDHC
Odp: GPS działa albo nie działa?
« Odpowiedź #27 : Listopad 11, 2008, 22:33:43 »
Rigel: a byłbyś łaskaw wyjaśnić obecnym forumowiczom, a także ich  potomnym, którzy za np. 20-30 lat być może przeczytają ten wątek ;) - cóż takiego uczyniłeś? Wysłałes sprzęt do serwisu, wgrałeś extra-magiczny soft, a może zrobiłeś HR, porządek, poustawiałeś wszystko jak należy? Oraz w jakim modelu, bo Asus wydał ich przeciez kilka... ?

Pozdrawiam -

Stanley


Offline Rigel

  • Newbie
  • Wiadomości: 9
Odp: GPS działa albo nie działa?
« Odpowiedź #28 : Listopad 17, 2008, 23:37:39 »
mam asusa 696 i porostu dzieki Visual GPS przestawiłem ustawienia

NMEA na
 GGA: 1
GLL: 0
GSA: 1 (może być też 5)
GSV: 5
RMC: 1
VTG: 1
MSS: 0
i baud 4800

podziałało.

ps: jesli chceie aby wam automapa szybciej łapała sygnał co jakis czas kasujcie folder "Data Files" naprawde pomaga :-)
 


Offline NixOne

  • Newbie
  • Wiadomości: 1
Odp: GPS działa albo nie działa?
« Odpowiedź #29 : Maj 23, 2009, 01:35:34 »
Witam,

Próbowałem naprawić mojego Asusa A686 tak jak tu opisano, bo problem chyba jest ten sam.

W ustawieniach (Ustawienia/System/External GPS) mam:
Port programu GPS - COM5
Port sprzętu GPS - COM4 / 4800
zaznaczone automatyczne zarządzanie

SirfTech po otwarciu na porcie COM5 / 4800 pokazał:
Protocol  NMEA
Messages 380 (i rośnie) NMEA SiRF 0
Baudrate NMEA 4800 Effective 0
Bytes 15808 (i rośnie)

można było zobaczyć aktualny czas UTC.

Gdy w GPS Monitorze w Tools/Command/NMEA ustawiłem:
GGA: 1
GLL: 1
GSA: 1
GSV: 5
RMC: 1
VTG: 1
MSS: 0
baud 4800

to pokazały się na czerwono satelity.
Na dole było: NMEA COM5: 4800 Invalid.
W trybie "Development" widać było sekwencje: VTG,RMC,GSV,GSA,GGA, czyli jak rozumiem te co powinny.

VisualGPSce jakoś się połączył, pokazał czas UTC, zielona dioda na palmtopie zaczyna mrugać, widzi około 10 satelitów ale z nich nie korzysta (satellites in use:0) więc nie łapie fixa, jako położenie pokazuje zera. W prawym dolnym rogu ekranu mruga czerwona lampka.

Proszę o pomoc bo już z tym dość długo walczę, a niedługo planuję wyjazd w dość daleką trasę...

Z góry dziękuję i pozdrawiam

EDIT: Widziałem kilka komentarzy osób którym nie działała żadna nawigacja oprócz iGO 2006 - zainstalowałem u siebie i działa, szybko łapie fixa. Natomiast iGO 8, AM 5 czy VisualGPSce w ogóle nie chcą łapać,  wszystkie satelity są zaznaczone na obrazku na czerwono.

« Ostatnia zmiana: Maj 23, 2009, 09:41:06 wysłana przez NixOne »